import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*/?\\s*(?!(?:a|strong|em)\\b)\\w+[^>]*>";
final String string = "<a href=\"https://www.example.com/page\">Example page</a> is a <strong>valid</strong> tag.\n"
+ "< em class=\"something\"> is also allowed</em>\n"
+ "But <param> or <argument> should be escaped.\n"
+ "This also: <br/> <\n"
+ "br />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}