$re = '/<\s*/?\s*(?!(?:a|strong|em)\b)\w+[^>]*>/';
$str = '<a href="https://www.example.com/page">Example page</a> is a <strong>valid</strong> tag.
< em class="something"> is also allowed</em>
But <param> or <argument> should be escaped.
This also: <br/> <
br />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);