import re
regex = re.compile(r"<\s*/?\s*(?!(?:a|strong|em)\b)\w+[^>]*>")
test_str = ("<a href=\"https://www.example.com/page\">Example page</a> is a <strong>valid</strong> tag.\n"
"< em class=\"something\"> is also allowed</em>\n"
"But <param> or <argument> should be escaped.\n"
"This also: <br/> <\n"
"br />")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")