re = /<\s*\/?\s*(?!(?:a|strong|em)\b)\w+[^>]*>/
str = '<a href="https://www.example.com/page">Example page</a> is a <strong>valid</strong> tag.
< em class="something"> is also allowed</em>
But <param> or <argument> should be escaped.
This also: <br/> <
br />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end