#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[\s*(/?)\s*((?:a|strong|em)\b)([^\]]*)\]"
Local $sString = "[a href="https://www.example.com/page"]Example page[/a] is a [strong]valid[/strong] tag." & @CRLF & _
"[em class="something"] is also allowed[/em]" & @CRLF & _
"But <param> or <argument> should be escaped." & @CRLF & _
"This also: <br/> <" & @CRLF & _
"br /> <script type="text/javascript">alert('xss'></script>" & @CRLF & _
"" & @CRLF & _
"Turn left <- or turn right ->" & @CRLF & _
"Also, accept this => or a smiley >.<"
Local $sSubst = "<\1\2\3>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)