package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\s*(/?)\s*((?:a|strong|em)\b)([^\]]*)\]`)
var str = `[a href="https://www.example.com/page"]Example page[/a] is a [strong]valid[/strong] tag.
[em class="something"] is also allowed[/em]
But <param> or <argument> should be escaped.
This also: <br/> <
br /> <script type="text/javascript">alert('xss'></script>
Turn left <- or turn right ->
Also, accept this => or a smiley >.<`
var substitution = "<\1\2\3>"
fmt.Println(re.ReplaceAllString(str, substitution))
}