using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\s*(/?)\s*((?:a|strong|em)\b)([^\]]*)\]";
string substitution = @"<\1\2\3>";
string input = @"[a href=""https://www.example.com/page""]Example page[/a] is a [strong]valid[/strong] tag.
[em class=""something""] is also allowed[/em]
But <param> or <argument> should be escaped.
This also: <br/> <
br /> <script type=""text/javascript"">alert('xss'></script>
Turn left <- or turn right ->
Also, accept this => or a smiley >.<";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}