# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[\s*(/?)\s*((?:a|strong|em)\b)([^\]]*)\]"
test_str = ("[a href=\"https://www.example.com/page\"]Example page[/a] is a [strong]valid[/strong] tag.\n"
"[em class=\"something\"] is also allowed[/em]\n"
"But <param> or <argument> should be escaped.\n"
"This also: <br/> <\n"
"br /> <script type=\"text/javascript\">alert('xss'></script>\n\n"
"Turn left <- or turn right ->\n"
"Also, accept this => or a smiley >.<")
subst = "<\\1\\2\\3>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.