using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d{50}|(?=.{51})\d+\.\d+)$";
string input = @"12345678901234567890123456789012345678901234567890
12345.123456789012345678901234567890123456789012345
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}