$re = '/^(?:\d{50}|(?=.{51})\d+\.\d+)$/m';
$str = '12345678901234567890123456789012345678901234567890
12345.123456789012345678901234567890123456789012345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);