const regex = /^(?:\d{50}|(?=.{51})\d+\.\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{50}|(?=.{51})\\d+\\.\\d+)$', 'gm')
const str = `12345678901234567890123456789012345678901234567890
12345.123456789012345678901234567890123456789012345
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}