re = /^(?:\d{50}|(?=.{51})\d+\.\d+)$/m
str = '12345678901234567890123456789012345678901234567890
12345.123456789012345678901234567890123456789012345
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end