package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<.*(bur).*?>`)
var str = `bench testedstarter, starter just makes noise, and <hasburnt> <electrical> smell.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}