$re = '/<.*(bur).*?>/m';
$str = 'bench testedstarter, starter just makes noise, and <hasburnt> <electrical> smell.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);