const regex = /<.*(bur).*?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<.*(bur).*?>', 'gm')
const str = `bench testedstarter, starter just makes noise, and <hasburnt> <electrical> smell.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}