# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^a]*a){2}[^a]*$//gm;t' <<< "affa
aa
ahaaa
xjhaKHa"