const regex = /^([^a]*a){2}[^a]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^a]*a){2}[^a]*$', 'gm')
const str = `affa
aa
ahaaa
xjhaKHa`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);