using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^a]*a){2}[^a]*$";
string substitution = @"";
string input = @"affa
aa
ahaaa
xjhaKHa";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}