$re = '/^([^a]*a){2}[^a]*$/m';
$str = 'affa
aa
ahaaa
xjhaKHa';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;