using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+:\d+(:\d+)?";
string substitution = @"<span class=""time"">$0</span>";
string input = @"Lorem 1:06:16 ips48:5um.
1:10 - some text<br>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}