import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+:\\d+(:\\d+)?";
final String string = "Lorem 1:06:16 ips48:5um.\n"
+ "1:10 - some text<br>";
final String subst = "<span class=\"time\">$0</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}