re = /\d+:\d+(:\d+)?/m
str = 'Lorem 1:06:16 ips48:5um.
1:10 - some text<br>'
subst = '<span class="time">$0</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result