import re
regex = re.compile(r"\d+:\d+(:\d+)?", flags=re.MULTILINE)
test_str = ("Lorem 1:06:16 ips48:5um.\n"
"1:10 - some text<br>")
subst = "<span class=\"time\">$0</span>"
result = regex.sub(subst, test_str)
if result:
print(result)