#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(15:58:45[\s\S]*?15:58:46)"
Local $sString = "2017-02-20 15:58:45.442 - [XYZ] 155 RADIO_TRAIN_TO_TRACK_INITIATION_COM_SESSION" & @CRLF & _
" .VAR1" & @CRLF & _
" .VAR2" & @CRLF & _
" .VAR3" & @CRLF & _
" .VAR4" & @CRLF & _
"2017-02-20 15:58:46.432 - [XYZ] 32 RADIO_TRACK_TO_TRAIN_CONFIGURATION_DETERMINATION" & @CRLF & _
" .VAR1" & @CRLF & _
" .VAR2" & @CRLF & _
" .VAR3" & @CRLF & _
" .VAR4" & @CRLF & _
" .VAR5" & @CRLF & _
" .VAR6" & @CRLF & _
"2017-02-20 15:58:48.541 - [XYZ] 155 RADIO_TRAIN_TO_TRACK_INITIATION_COM_SESSION" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")