import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(15:58:45[\\s\\S]*?15:58:46)";
final String string = "2017-02-20 15:58:45.442 - [XYZ] 155 RADIO_TRAIN_TO_TRACK_INITIATION_COM_SESSION\n"
+ " .VAR1\n"
+ " .VAR2\n"
+ " .VAR3\n"
+ " .VAR4\n"
+ "2017-02-20 15:58:46.432 - [XYZ] 32 RADIO_TRACK_TO_TRAIN_CONFIGURATION_DETERMINATION\n"
+ " .VAR1\n"
+ " .VAR2\n"
+ " .VAR3\n"
+ " .VAR4\n"
+ " .VAR5\n"
+ " .VAR6\n"
+ "2017-02-20 15:58:48.541 - [XYZ] 155 RADIO_TRAIN_TO_TRACK_INITIATION_COM_SESSION\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}