package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(15:58:45[\s\S]*?15:58:46)`)
var str = `2017-02-20 15:58:45.442 - [XYZ] 155 RADIO_TRAIN_TO_TRACK_INITIATION_COM_SESSION
.VAR1
.VAR2
.VAR3
.VAR4
2017-02-20 15:58:46.432 - [XYZ] 32 RADIO_TRACK_TO_TRAIN_CONFIGURATION_DETERMINATION
.VAR1
.VAR2
.VAR3
.VAR4
.VAR5
.VAR6
2017-02-20 15:58:48.541 - [XYZ] 155 RADIO_TRAIN_TO_TRACK_INITIATION_COM_SESSION
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}