import re
regex = re.compile(r"(15:58:45[\s\S]*?15:58:46)")
test_str = ("2017-02-20 15:58:45.442 - [XYZ] 155 RADIO_TRAIN_TO_TRACK_INITIATION_COM_SESSION\n"
" .VAR1\n"
" .VAR2\n"
" .VAR3\n"
" .VAR4\n"
"2017-02-20 15:58:46.432 - [XYZ] 32 RADIO_TRACK_TO_TRAIN_CONFIGURATION_DETERMINATION\n"
" .VAR1\n"
" .VAR2\n"
" .VAR3\n"
" .VAR4\n"
" .VAR5\n"
" .VAR6\n"
"2017-02-20 15:58:48.541 - [XYZ] 155 RADIO_TRAIN_TO_TRACK_INITIATION_COM_SESSION\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")