# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?=\s*[}\]])//gm;t' <<< "{
\"markers\": [
{
\"name\": \"Rixos The Palm Dubai\",
\"position\": [25.1212, 55.1535],
},
{
\"name\": \"Shangri-La Hotel\",
\"description\": \"some description\",
},
{
\"value\": 123445,
}
]
}"