using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=\s*[}\]])";
string substitution = @"";
string input = @"{
""markers"": [
{
""name"": ""Rixos The Palm Dubai"",
""position"": [25.1212, 55.1535],
},
{
""name"": ""Shangri-La Hotel"",
""description"": ""some description"",
},
{
""value"": 123445,
}
]
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}