# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r",(?=\s*[}\]])"
test_str = ("{\n"
" \"markers\": [\n"
" {\n"
" \"name\": \"Rixos The Palm Dubai\",\n"
" \"position\": [25.1212, 55.1535],\n"
" },\n"
" {\n"
" \"name\": \"Shangri-La Hotel\",\n"
" \"description\": \"some description\",\n"
" },\n"
" {\n"
" \"value\": 123445,\n"
" }\n"
" ]\n"
"}")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.