import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?=\\s*[\\}\\]])";
final String string = "{\n"
+ " \"markers\": [\n"
+ " {\n"
+ " \"name\": \"Rixos The Palm Dubai\",\n"
+ " \"position\": [25.1212, 55.1535],\n"
+ " },\n"
+ " {\n"
+ " \"name\": \"Shangri-La Hotel\",\n"
+ " \"description\": \"some description\",\n"
+ " },\n"
+ " {\n"
+ " \"value\": 123445,\n"
+ " }\n"
+ " ]\n"
+ "}";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}