# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{3})(\d{3})(\d{2})(\d{2})/$1-$2-$3-$4/;t' <<< "0321994245
"