#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d{3})(\d{3})(\d{2})(\d{2})"
Local $sString = "0321994245" & @CRLF & _
""
Local $sSubst = "$1-$2-$3-$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)