$re = '/(\d{3})(\d{3})(\d{2})(\d{2})/';
$str = '0321994245
';
$subst = "$1-$2-$3-$4";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;