re = /(\d{3})(\d{3})(\d{2})(\d{2})/
str = '0321994245
'
subst = '$1-$2-$3-$4'
result = str.sub(re, subst)
# Print the result of the substitution
puts result