import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!0+[dmy]\\b)\\d+[dmy]\\b";
final String string = "1d\n"
+ "30m\n"
+ "1232y\n"
+ "10m\n"
+ "10m\n"
+ "00m\n\n\n"
+ "e.g. Invalid\n\n"
+ "1dd\n"
+ "30mm\n"
+ "1232yyy";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}