import re
regex = re.compile(r"\b(?!0+[dmy]\b)\d+[dmy]\b", flags=re.MULTILINE)
test_str = ("1d\n"
"30m\n"
"1232y\n"
"10m\n"
"10m\n"
"00m\n\n\n"
"e.g. Invalid\n\n"
"1dd\n"
"30mm\n"
"1232yyy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")