re = /\b(?!0+[dmy]\b)\d+[dmy]\b/m
str = '1d
30m
1232y
10m
10m
00m
e.g. Invalid
1dd
30mm
1232yyy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end