$re = '/\b(?!0+[dmy]\b)\d+[dmy]\b/m';
$str = '1d
30m
1232y
10m
10m
00m
e.g. Invalid
1dd
30mm
1232yyy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);