#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:Data|Field)\h*\S.*"
Local $sString = "Data " & @CRLF & _
"Data " & @CRLF & _
"Datatest1" & @CRLF & _
"Data test" & @CRLF & _
"Data 867$33@!.//()7" & @CRLF & _
"Field somthing" & @CRLF & _
"Field "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")