$re = '/(?:Data|Field)\h*\S.*/';
$str = 'Data
Data
Datatest1
Data test
Data 867$33@!.//()7
Field somthing
Field ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);