package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:Data|Field)\h*\S.*`)
var str = `Data
Data
Datatest1
Data test
Data 867$33@!.//()7
Field somthing
Field `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}