// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:Data|Field)\h*\S.*").unwrap();
let string = "Data
Data
Datatest1
Data test
Data 867$33@!.//()7
Field somthing
Field ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}