#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?P<MovieCode>(?!Deku)[A-Za-z]{3,6}-\d{3,5})(?P<MoviePart>[A-C]{1}\b)?"
Local $sString = "Deku-040414-575-nyap2p.com.mp4" & @CRLF & _
"jjre-107.1080p" & @CRLF & _
"MRZ-249Capricorn" & @CRLF & _
"THAT-025-youlove" & @CRLF & _
"www.google.com-CRAP-038" & @CRLF & _
"MYMR-249Capricorn" & @CRLF & _
"MYMR-249A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")