$re = '/(?P<MovieCode>(?!Deku)[A-Za-z]{3,6}-\d{3,5})(?P<MoviePart>[A-C]{1}\b)?/mi';
$str = 'Deku-040414-575-nyap2p.com.mp4
jjre-107.1080p
MRZ-249Capricorn
THAT-025-youlove
www.google.com-CRAP-038
MYMR-249Capricorn
MYMR-249A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);