using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<MovieCode>(?!Deku)[A-Za-z]{3,6}-\d{3,5})(?P<MoviePart>[A-C]{1}\b)?";
string input = @"Deku-040414-575-nyap2p.com.mp4
jjre-107.1080p
MRZ-249Capricorn
THAT-025-youlove
www.google.com-CRAP-038
MYMR-249Capricorn
MYMR-249A";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}