import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<MovieCode>(?!Deku)[A-Za-z]{3,6}-\\d{3,5})(?P<MoviePart>[A-C]{1}\\b)?";
final String string = "Deku-040414-575-nyap2p.com.mp4\n"
+ "jjre-107.1080p\n"
+ "MRZ-249Capricorn\n"
+ "THAT-025-youlove\n"
+ "www.google.com-CRAP-038\n"
+ "MYMR-249Capricorn\n"
+ "MYMR-249A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}