using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"qw=([A-Za-z0-9]+)&pag=([0-9]+)";
string input = @"/Material/Index?qw=palavraChave&pag=1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}