re = /qw=([A-Za-z0-9]+)&pag=([0-9]+)/
str = '/Material/Index?qw=palavraChave&pag=1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end