package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`qw=([A-Za-z0-9]+)&pag=([0-9]+)`)
var str = `/Material/Index?qw=palavraChave&pag=1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}